Commit da36958d authored by Simon Welsh's avatar Simon Welsh

Merge branch 'use-conflicts' into 'phpunit-5.1'

Move phpunit to conflict

Rather than requiring phpunit, mark the HHI as conflicting with older versions.

This achieves the same benefit of requiring a version of PHPUnit that matches the HHI version without the downside of forcing PHPUnit into projects when one of their dependancies uses the HHI files so that its tests are type safe.

See #8.

See merge request !7
parents 601713c5 20810df3
......@@ -5,8 +5,7 @@
"homepage": "https://git.simon.geek.nz/91-carriage/phpunit-hhi",
"license": ["MIT"],
"require": {
"hhvm": ">=3.9.0",
"phpunit/phpunit": "~5.1.0"
"hhvm": ">=3.9.0"
},
"extra": {
"branch-alias": {
......@@ -16,6 +15,9 @@
"dev-phpunit-4.8": "4.8.x-dev"
}
},
"conflict": {
"phpunit/phpunit": "<5.1.0"
},
"support": {
"issues": "https://git.simon.geek.nz/91-carriage/phpunit-hhi/issues",
"source": "https://git.simon.geek.nz/91-carriage/phpunit-hhi/tree/phpunit-5.1"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment