Update HHI to later 5.7 releases

Now matches PHPUnit 5.7.19 and requires at least 5.7.15 due to the
addition of getCountOfGenerator to PHPUnit_Framework_Constraint_Count.
5 jobs for 5.7.1 in 4 minutes and 45 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Typecheck
failed #773
docker
hack

00:02:09

failed #772
docker
hack-min

00:04:05

 
  Test
skipped #775
docker
phpunit
skipped #774
docker
phpunit-min
 
  Deploy
skipped #776
docker
packagist
 
Name Stage Failure
failed
hack-min Typecheck There is an unknown failure, please try again
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for 91carriage/phpunit-hhi No version set (parsed as 1.0.0) -> satisfiable by 91carriage/phpunit-hhi[No version set (parsed as 1.0.0)].
- phpunit/phpunit 5.7.9 conflicts with 91carriage/phpunit-hhi[No version set (parsed as 1.0.0)].
- Installation request for phpunit/phpunit 5.7.9 -> satisfiable by phpunit/phpunit[5.7.9].

ERROR: Job failed: exit code 1
failed
hack Typecheck There is an unknown failure, please try again
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for 91carriage/phpunit-hhi No version set (parsed as 1.0.0) -> satisfiable by 91carriage/phpunit-hhi[No version set (parsed as 1.0.0)].
- phpunit/phpunit 5.7.9 conflicts with 91carriage/phpunit-hhi[No version set (parsed as 1.0.0)].
- Installation request for phpunit/phpunit 5.7.9 -> satisfiable by phpunit/phpunit[5.7.9].

ERROR: Job failed: exit code 1