Commit e421e558 authored by Simon Welsh's avatar Simon Welsh

Switch to using docker for tests

Also bump minimum version to 3.12 since that's the oldest I can test
parent 7cf2db21
Pipeline #173 failed with stages
in 1 minute and 26 seconds
......@@ -11,33 +11,37 @@ cache:
paths:
- vendor/
#hack-min:
#script:
#- hh_server --check .
#stage: typecheck
#tags:
#- hhvm-3.9
hack-min:
script:
- hh_server --check .
stage: typecheck
image: hhvm/hhvm:3.12-lts-latest
tags:
- docker
hack:
script:
- hh_server --check .
stage: typecheck
image: hhvm/hhvm:latest
tags:
- hhvm
- docker
#phpunit-min:
#script:
#- hhvm vendor/bin/phpunit --bootstrap tests/HHITest.php tests/
#stage: test
#tags:
#- hhvm-3.9
phpunit-min:
script:
- hhvm vendor/bin/phpunit --bootstrap tests/HHITest.php tests/
stage: test
image: hhvm/hhvm:3.12-lts-latest
tags:
- docker
phpunit:
script:
- hhvm vendor/bin/phpunit --bootstrap tests/HHITest.php tests/
stage: test
image: hhvm/hhvm:latest
tags:
- hhvm
- docker
packagist:
stage: deploy
......@@ -48,3 +52,5 @@ packagist:
-H 'content-type:application/json' \
\"https://packagist.org/api/update-package?username=simon_w&apiToken=$PACKAGIST_TOKEN\" \
-d '{\"repository\":{\"url\":\"https://git.simon.geek.nz/91-carriage/phpunit-hhi.git\"}}'"
tags:
- docker
......@@ -5,7 +5,7 @@
"homepage": "https://git.simon.geek.nz/91-carriage/phpunit-hhi",
"license": ["MIT"],
"require": {
"hhvm": ">=3.9.0"
"hhvm": ">=3.12.0"
},
"extra": {
"branch-alias": {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment